Žilinská univerzita > Fakulta riadenia a informatiky > Katedra informačných sietí

Postup tvorby deb balíčkov SIP servera Kamailio

apt-get install git-core make devscripts dpatch

 

Následne sme nainštalovali závislosti pre Kamailio:

 

apt-get install libdb-dev xsltproc libcurl4-openssl-dev docbook-xml libpurple-dev libmemcache-dev libreadline-dev python-dev liblua5.1-0-dev libsasl2-dev flex bison libmysqlclient15-dev zlib1g-dev libxml2 libxml2-dev libradiusclient-ng2 libradiusclient-ng-dev libpq-dev libpq5 libexpat1-dev libexpat1 unixodbc unixodbc-dev libxmlrpc-c3 libxmlrpc-c3-dev libperl-dev libperl5.10 libsnmp-dev libldap2-dev libldap-2.4-2 libconfuse-dev libconfuse0 libpcre3 libpcre3-dev libsctp-dev libsctp1

  

Pretože Kamailio vyžaduje knižnice a zdrojové súbory libgeoip verzie >= 1.4.5 a v repozitároch je verzia 1.4.4, stiahli sme verziu 1.4.7 z debian backports:

 

wget http://ftp.at.debian.org/debian-backports//pool/main/g/geoip/libgeoip-de...

wget http://backports.debian.or.at/debian-backports/pool/main/g/geoip/libgeoip1_1.4.7~beta6+dfsg-1~bpo50+1_amd64.deb

 

 

Pomocou manžéra dpkg sme nainštalovali stiahnuté balíčky:

 

dpkg -i *.deb

 

Vytvorili sme si nový priečinok kamailio a presunuli sa do neho:

 

mkdir kamailio && cd kamailio

 

Pomocou git clone sme naklonovali git repozitár do priečinku kamailio-3.1.3:
 

git clone --depth 1 git://git.sip-router.org/sip-router kamailio-3.1.3

  

Vytvoril sa nový priečinok kamailio-3.1.3, do ktorého sme sa presunuli:

 

cd kamailio-3.1.3/

 
 

Nasledovný príkaz spôsobí, že sa prepneme na verziu 3.1:

 

git checkout -b 3.1 origin/3.1

  

Ak je premenná FLAVOUR nastavená na 'kamailio', premenná C_INSTALL_UTILS bude obsahovať zoznam adresárov utilít, ktoré sa budú inštalovať spolu s kamailiom. Príkaz vytvorí konfiguračný súbor modules.lst, v ktorom sa nachádza zoznam modulov, ktoré sa budú, prípadne nebudú zahrnuté v procese tvorby balíčkov

 

make FLAVOUR=kamailio cfg

 

V súbore modules.lst, je potom možné upravovať zoznam modulov, ktoré sa budú kompilovať. My sme len odstránili z premennej exclude_modules 'db_mysql'.

 

 Následne sme vytvorili binárne balíčky, ktoré sú umiestnené v adresári o úroveň vyššie:

make deb

  

Zoznam vytvorených súborov po spustení make deb:

  

kamailio_3.1.3_amd64.changes

kamailio_3.1.3_amd64.deb

kamailio_3.1.3.dsc

kamailio_3.1.3.tar.gz

kamailio-berkeley-modules_3.1.3_amd64.deb

kamailio-carrierroute-modules_3.1.3_amd64.deb

kamailio-cpl-modules_3.1.3_amd64.deb

kamailio-geoip-modules_3.1.3_amd64.deb

kamailio-ldap-modules_3.1.3_amd64.deb

kamailio-lua-modules_3.1.3_amd64.deb

kamailio-memcached-modules_3.1.3_amd64.deb

kamailio-mysql-modules_3.1.3_amd64.deb

kamailio-nth_3.1.3_amd64.deb

kamailio-perl-modules_3.1.3_amd64.deb

kamailio-postgres-modules_3.1.3_amd64.deb

kamailio-presence-modules_3.1.3_amd64.deb

kamailio-purple-modules_3.1.3_amd64.deb

kamailio-python-modules_3.1.3_amd64.deb

kamailio-radius-modules_3.1.3_amd64.deb

kamailio-snmpstats-modules_3.1.3_amd64.deb

kamailio-tls-modules_3.1.3_amd64.deb

kamailio-unixodbc-modules_3.1.3_amd64.deb

kamailio-utils-modules_3.1.3_amd64.deb

kamailio-xml-modules_3.1.3_amd64.deb

kamailio-xmlrpc-modules_3.1.3_amd64.deb

kamailio-xmpp-modules_3.1.3_amd64.deb

 

Poznámka:
 

Počas kompilácie sa môže stať, že sa vyskytne chyba súvisiaca s knižnicou libpurple, stiahli sme teda zdrojové súbory IM klienta pidgin verzie 2.4.3 a presunuli priečinok libpurple do /usr/local/include/

   

Chyba:

 

In file included from purple.h:23,

from clientpipe.c:28:

/usr/local/include/libpurple/status.h:93: error: expected specifier-qualifier-list before ‘gpointer’

make[3]: *** [clientpipe.o] Error 1

 

 

 

Riešenie:

 

mkdir pidgin && cd pidgin

wget http://downloads.sourceforge.net/project/pidgin/Pidgin/2.4.3/pidgin-2.4....

tar xjvf pidgin-2.4.3.tar.bz2

mv /usr/local/include/libpurple/ /usr/local/include/.libpurple-old

cp -rv ./pidgin-2.4.3/libpurple/ /usr/local/include/.libpurple-2.4.3

ln -s /usr/local/include/.libpurple-2.4.3/ /usr/local/include/libpurple

 

AttachmentSize
File doc_kamailio_deb_edt.pdf388.11 KB
Groups: